Выполнение работы. 1. Для отделения корней аналитическим методом необходимо протабулировать функцию на некотором отрезке [Хнач
Лекции.Орг

Поиск:


Выполнение работы. 1. Для отделения корней аналитическим методом необходимо протабулировать функцию на некотором отрезке [Хнач




1. Для отделения корней аналитическим методом необходимо протабулировать функцию на некотором отрезке [Хнач, Хкон] и определить соседние точки, в которых функция принимает значения разных знаков.

Анализ функции показывает, что область допустимых значений данной функции имеет вид [-4, + Исходя из этого, для табулирования возьмем отрезок [-4, 6].

Разобьем задание на два этапа и каждый будем оформлять на отдельном листе.

Первый лист назовите «Отделение корней». Оформите заголовок таблицы и введите исходные данные в соответствии с рисунком 1.

Рисунок 1 – Образец оформления таблицы

Введите в таблицу основные формулы. Для того, чтобы вычисления начинались с Хнач, приравняем ячейку В7 Хнач, т.е. формула будет выглядеть так: =А4. Начиная с ячейки В8 необходимо предыдущее значение Х увеличивать на величину шага. При этом нужно следить чтобы, значение Х не превысило верхнюю границу отрезка табулирования. Если же очередное значение Х превышает Хкон, то в соответствующей ячейке необходимо выдать надпись «СТОП». Таким образом, в ячейке В8 должна быть введена следующая формула: =ЕСЛИ(B7+$C$4>$B$4;"СТОП";B7+$C$4). Полученную формулу распространите вниз до появления слова «СТОП».

Для вычисления значений Y в ячейку С7 введите формулу вычисления заданной функции и распространите ее на весь диапазон вычисления.

В столбце D вводится комментарий, который поможет отделить корни данного уравнения. Поскольку необходимо сравнивать два соседних значения Y, первую формулу с комментарием будем вводить в ячейку D8. Смысл проверки заключается в том, чтобы сравнить два значении Yи определить имеют они одинаковые знаки или уже нет. В первом случае на данном отрезке корней уравнения нет, во втором – есть. Тогда в комментарии требуется получить сообщение с указанием данного отрезка. Формула вывода комментария, учитывающая перечисленные выше условия, должна выглядеть следующим образом:=ЕСЛИ(C7*C8<0;"Корень на отрезке "&B7&"…"&B8;"----"). На рисунке 2 показан пример таблицы отделения корней уравнения.

 

Рисунок 2 – Образец таблицы отделения корней уравнения

 

В следующих двух столбцах вычисляются первая и вторая производные функции . В точке не существует ни первая, ни вторая производная, поэтому формулы будем вводить, начиная с восьмой строки. Введите в соответствующие ячейки формулы для вычисления: и .

ВыводВ результате отделения корней найдены два отрезка, каждый из которых содержит один корень уравнения.

2. Найдем кореньуравнения на отрезке [1, 2] с точностью ε=0,001 методом бисекций.

Начнем с оформления таблицы. В первой строке укажите название, в третью и четвертую строки введите исходные данные, то есть начало и конец отрезка, требуемую погрешность. В шестую строку введите шапку таблицы, как приведено на рисунке 3.

Рисунок 3 – Образец оформления таблицы решения уравнения

Начальные значения в ячейках А7 и В7 приравняем исходным данным, С7 вычисляется как середина отрезка [a, b], в столбцах D,E и F вычисляется значение функции от соответствующих переменных. ВА ячейке G7 необходимо определить погрешность вычисления. Если , то корень считается найденным и необходимо выдать ответ. В противном случае, выдается Таким образом, формула, введенная в ячейку G7можетвыглядеть следующим образом: =ЕСЛИ(ABS(B7-A7)<2*$C$4;"Корень="&C7;ABS(B7-A7)). Поясните, с какой целью в данную формулу введен знак &.

В следующих ячейках столбцов А и В, в соответствии с методом бисекций, следует из отрезков [a, c] и [c, b] выбирать тот, на концах которого функция принимает значения разных знаков. В ячейке А8 формула должна выглядеть так: =ЕСЛИ(D7*F7<0;A7;C7). В ячейку В8 формулу введите самостоятельно.

Полученные формулы растяните на следующие строки до тех пор, пока в столбце Gне появится фраза «Корень=…». На рисунке 4 приведен пример решения нелинейного уравнения методом бисекций.

Рисунок 4 - Пример решения нелинейного уравнения методом бисекций

 

Приближенное решение уравнениЙ методом ХОРД

 

Цель работы:определить корень уравнения, приведенного в задании, используя метод хорд, средствами MS EXCEL.

Задание: найти корень уравнения с точностью ε=0,001 методом хорд.





Дата добавления: 2015-05-05; просмотров: 530 | Нарушение авторских прав | Изречения для студентов


Читайте также:

Рекомендуемый контект:


Поиск на сайте:



© 2015-2020 lektsii.org - Контакты - Последнее добавление

Ген: 0.002 с.