Лекции.Орг


Поиск:




Примеры простейших отчетных ведомостей




В книге ФИНАНСОВЫЙ АНАЛИЗ создайте новый лист (меню ВСТАВКА\ЛИСТ). Все упражнения в данного раздела лабораторной работе выполняйте на Листе7. Лист7 переименуйте в Примеры списков.

Прежде чем обратиться к примерам составления отчетных ведомостей, рассмотрим средство создания списков, которое очень ускоряет и облегчает создание таблиц в Excel. На рис.4.8.1 приведены примеры допустимых списков.

Рис.4.8.1. Примеры списков

Для создания любого из приведенных списков, за исключением столбца G, достаточно ввести в ячейку первый элемент списка, выделить ячейку, установить указатель мыши на маркер заполнения ячейки и протащить его вдоль столбца (строки) до тех пор, пока не будет создан требуемый ряд. На вкладке Списки (Custom Lists) диалогового окна Параметры (Options) (рис.4.8.2), открываемого командой Сервис, Параметры (Tools, Options), приведены встроенные в Excel списки, которые представляют собой последовательности названий месяцев и дней недели.

Рис.4.8.2. Вкладка Списки диалогового окна Параметры

Используя вкладку Списки (Custom Lists), можно создавать пользовательские списки. Элементы списка пользователя надо ввести в поле Элементы списка (List Entries), причем каждый элемент вводится с новой строки. Если нажать кнопку Добавить (Add), то созданный список будет занесен в библиотеку списков. Список можно также добавить и непосредственно с рабочего листа, указав в поле Импорт списка из ячеек (Import List from Cells) диапазон, из которого импортируется список.

Кроме стандартных списков, занесенных в библиотеку. Excel позволяет легко создавать по приведенному выше алгоритму последовательности с текстом и порядковыми номерами (рис.4.8.1, столбцы Е, F и Н). Если номера меняются с шагом, отличным от единицы, необходимо в две соседние ячейки ввести первые два члена последовательности, например, экспо 87 в G1 и экспо 89 в G2, затем выделить диапазон G1:G2, установить указатель мыши на маркер заполнения диапазона и протащить его вдоль столбца до тех пор, пока не будет создан требуемый ряд.

Перед началом создания первой отчетной ведомости пополним наши знания, рассмотрев синтаксис трех функций, наиболее часто встречающихся при расчетах в таблицах: сумм, срзнач и ранг.

Функция сумм (SUM) находит сумму чисел из указанного диапазона ячеек.

 

Синтаксис:

СУММ(число1; число2;...), где число1, число2,... — числа, которые суммируются.

Функция срзнач (average) находит среднее значение чисел из указанного диапазона ячеек.

 

Синтаксис:

СРЗНАЧ(число1; число2;...). Аргументы — те же, что и у функции сумм.

Функция ранг (rank) возвращает ранг числа в списке чисел. Ранг числа - это его величина относительно других значений в списке. (Если список отсортировать, то ранг числа будет его позицией).

 

Синтаксис:

РАНГ(число; ссылка; порядок)

 

Аргументы:

число - число, для которого определяется ранг; ссылка - массив или ссылка на список чисел. Нечисловые значения в ссылке игнорируются; порядок - число, определяющее способ упорядочения. Если порядок равен 0 или опущен, то Excel определяет ранг числа так, как если бы ссылка была списком, отсортированным в порядке убывания. Если порядок — любое ненулевое число, то Excel определяет ранг числа так, как если бы ссылка была списком, отсортированным в порядке возрастания.

Отметим, что функция ранг присваивает повторяющимся числам одинаковый ранг.

Вооружившись навыками работы со списками и знаниями о функциях сумм, срзнач и ранг перейдем к созданию двух отчетных таблиц.

 

Первый пример.

В книге ФИНАНСОВЫЙ АНАЛИЗ создайте новый лист (меню ВСТАВКА\ЛИСТ). Все упражнения в данного раздела лабораторной работе выполняйте на Листе8. Лист8 переименуйте в «Отчетная ведомость по магазинам».

Сначала обсудим, как создать отчетную ведомость о результатах работы сети магазинов, приведенную на рис.4.8.2.

 

Рис.4.8.2. Отчетная ведомость о работе сети магазинов за июнь — август

 

В ячейку Е4 введем формулу:

=СУММ(В4:D4),

которую с помощью маркера заполнения протащим на диапазон Е4:Е9. В ячейку В 10 введем формулу:

=СУММ(В4:В9),

которую протащим на диапазон В10:Е10. В ячейку G4 введем формулу:

=СРЗНАЧ(В4:D4),

которую протащим на диапазон G4:G9. В ячейку Н4 введем формулу:

=Е4/$Е$10,

которую протащим на диапазон Н4:Н9. После чего диапазону ячеек H4:H9 назначим формат с помощью кнопки на панели инструментов:

 

Заметим, что знак $, стоящий перед буквой в имени ячейки, дает абсолютную ссылку на столбец с данным именем, а знак $, стоящий перед цифрой в имени ячейки, дает абсолютную ссылку на строку с этим именем. Поэтому если в формуле буква, входящая в имя ячейки, окружена с двух сторон знаками $, это означает, что в формуле дается не относительный, а абсолютный адрес ячейки, т. е. адрес, не подлежащий изменению при протаскивании формулы.

Для ввода в формулу абсолютного адреса ячейки достаточно после ввода ее относительного адреса нажать клавишу <F4>. Если бы в ячейку Н4 была введена формула =Е4/Е10, то ее протаскивание на ячейки Н5:Н9 привело бы к неверному результату. Присвоение ячейке имени с помощью команды Вставка / Имя / Присвоить (Inset, Name, Define) дает другой способ абсолютной адресации ячейки. Например, если бы ячейке Е10 было присвоено имя итого, то в ячейку Н4 можно было бы ввести формулу:

=Е4/Итого

которую затем протаскиваем на диапазон Н4:Н9. Для нахождения места магазина по объему продаж введем в ячейку F4 формулу:

=РАНГ(Е4;$Е$4:$Е$9),

которую протаскиваем на диапазон F4:F9.

С помощью функции частота (frequency) подсчитаем для данного множества суммарных выручек магазинов, сколько значений попадает в интервалы от 0 до 1000, от 1001 до 1100, от 1101 до 1200 и свыше 1201 млн. руб. С этой целью в диапазон ячеек 14:16 введем верхние границы этих интервалов: 1000, 1100 и 1200, соответственно, а в диапазон ячеек J4:J7 введем формулу:

{=ЧАСТОТА(Е4:E9;I4:I6)}

Фигурные скобочки не вводите вручную. После того как Вы наберете функцию нажмите одновременно три клавиши: Ctrl+Shift+Enter и скобки появяться автоматически. Если в последующем Вы решите внести изменения в функцию, то после обязательно, нажмите эти же клавиши, иначе у Вас появиться сообщение об ошибке.

Данная формула выведет в ячейку J4, сколько значений находится в интервале от 0 до 1000, в ячейку J5 — от 1001 до 1 100, в ячейку J6 — от 1 101 до 1 200, в ячейку J7 — сколько значений будет не меньше 1201.

Функция частота возвращает распределение частот в виде вертикального массива. Для данного множества значений и данного множества карманов (интервалов, в математическом смысле) частотное распределение подсчитывает, сколько исходных значений попадает в каждый интервал.

 

Синтаксис: ЧАСТОТА(массив_данных; массив_карманов).

Аргументы:

массив_данных - массив или ссылка на множество данных, для которых вычисляются частоты; если массив_данных не содержит значений, то функция частота возвращает массив нулей; массив_карманов- массив или ссылка на множество интервалов, в которые группируются значения аргумента массив_данных; если массив_карманов не содержит значений, то функция частота возвращает количество элементов в аргументе массив данных.

Частоты можно также вычислить, воспользовавшись диалоговым окном Анализ данных (Data Analysis), которое открывается командой Сервис / Анализ данных (Tools, Data Analysis). Средство анализа данных является одной из надстроек Excel. Если в меню Сервис (Tools) отсутствует команда Анализ данных (Data Analysis), то для ее установки нужно выполнить команду Сервис / Надстройки / Analysis ToolPak (Tools, Add-ins, Analysis ToolPak).

После выбора пункта Гистограмма (Histogram) в диалоговом окне Анализ данных (Data Analysis) откроется диалоговое окно Гистограмма (Histogram) (рис.4.8.3).

Рис.4.8.3. Диалоговое окно Гистограмма

 

В поле Входной интервал (Input Range) введем диапазон Е4:Е9, по которому строим гистограмму. В поле Интервал карманов (Bin Range) введем диапазон I4:I6 со значениями верхних границ интервалов. Гистограмма строится на новом рабочем листе или на текущем листе с указанием диапазона ячеек для результата. В данном случае в поле ввода Выходной интервал (Output Range) введем диапазон L4:L7. На рис. 4.8.4 приведен результат построения гистограммы.

Рис. 4.8.4. Результат построения гистограммы

Второй пример.

В книге ФИНАНСОВЫЙ АНАЛИЗ создайте новый лист (меню ВСТАВКА\ЛИСТ). Все упражнения в данного раздела лабораторной работе выполняйте на Листе9. Лист9 переименуйте в «Итоговая выручка».

Рассмотрим еще один пример составления отчетной ведомости, в которой по объему реализованных товаров рассчитывается итоговая выручка (рис.4.8.5).

В ячейки А22:С22 введены стоимости трех различных товаров, а в ячейки B25:D27 — объемы их реализации по месяцам. Для того чтобы вычислить суммарную стоимость реализованных товаров по месяцам, введем в ячейки Е25:Е27 формулу:

{=МУМНОЖ(В25:D27;ТРАНСП(А22:С22)}

Отметим, что данную таблицу можно было заполнить и без привлечения матричных формул. Можно ввести в ячейку Е27 формулу:

=СУММПРОИЗВ(В25:D25;$А$22:$С$22)

и протащить ее на диапазон Е25:Е27. Функция суммпроизв (sumproduct) вычисляет сумму произведений элементов указанных диапазонов ячеек.

Рис. 4.8.5. Расчет итоговой выручки по объему реализации

При построении гистограммы (рис. 4.8.5) в поле ввода первого диалогового окна Мастер диаграмм (Cart Wizard) введите диапазоны А25:А27; Е25:Е27. Напоминаем, что для одновременного выделения диапазонов, которые не примыкают друг к другу, сначала необходимо выделить

Лекция №9. Технология решения экономических задач с применением финансовых функций Excel. Пример отчетной ведомости по расчету просроченных платежей

В книге ФИНАНСОВЫЙ АНАЛИЗ создайте новый лист (меню ВСТАВКА\ЛИСТ). Все упражнения в данного раздела лабораторной работе выполняйте на Листе10. Лист10 переименуйте в «Расчет просроченных платежей».

Рассмотрим пример составления отчетной ведомости фирмы, продающей компьютеры, позволяющей определить количество и сумму просроченных клиентами платежей (рис.4.8.6).

Дата переучета введена в ячейку F2 с помощью формулы:

=ДАТА(98;7;31)

Функция дата (date) возвращает дату в числовом формате.

 

Синтаксис: ДАТА(год; месяц; день)

 

Рис.4.8.6. Расчет просроченных платежей

Аргументы:

год - число от 1900 до 2078; месяц - число, представляющее номер месяца в году. Если оно больше 12, то прибавляется к первому месяцу указанного года. Например, дата (96; 14;2) возвращает числовой формат даты 2 февраля 1997 года; день - число, представляющее номер дня в месяце. Если оно больше числа дней в указанном месяце, то прибавляется к первому дню указанного месяца

В ячейку Е2 введена формула, определяющая срок просрочки:

=ЕСЛИ(D2=0;$F$2-С2;""),

которая протаскивается на диапазон ЕЗ:Е20. В ячейки G8, G9 и G10 введены следующие формулы:

(=СУММ((Е2:Е20>0)*(Е2:Е20<=29)*(В2:В20))} {=СУММ((Е2:Е20>=30)*(Е2:Е20<=39)*(В2:В20))} {=СУММ((Е2:Е20>=40)*(В2:В20))},

вычисляющие суммарные стоимости просроченных оплат сроком до 29 дней, от 30 до 39 дней и свыше 40 дней.

Дадим пояснения к третьей из этих формул. Excel в формуле массива возвращает условие (Е2:Е20>=40) в виде массива, состоящего из 0 и 1, где о стоит на месте ячейки со значением меньше 40 и 1 — на месте ячейки со значением не меньше 40. Следовательно, данная формула вычисляет сумму произведений элементов массива (Е2:Е20>=40) (с единицами в случае просрочки на указанный срок и нулями — в противном случае) и массива В2:В20 (с ценами процессоров). Таким образом, третья формула возвращает суммарную стоимость заказов, просроченных не менее чем на 40 дней.

В ячейки G2, G3 и G4 введены формулы:

{=СУММ((Е2:Е20>0)*(Е2:Е20<=29))}

{=СУММ((Е2:Е20>=30)*(Е2:Е20<40))}

=СЧЁТЕСЛИ(Е2:Е20;">=40"),

вычисляющие количество просроченных оплат сроком до 29 дней, от 30 до 39 дней и свыше 40 дней.

Функция счётесли (COUNTIF) возвращает количество ячеек внутри указанного интервала, удовлетворяющих заданному критерию.

Синтаксис: СЧЁТЕСЛИ(интервал; критерий)

 

Аргументы:

интервал - интервал, в котором нужно подсчитать ячейки; критерий - критерий в форме числа, выражения или текста, который определяет, какие ячейки надо подсчитывать (например, критерий может быть выражен следующим образом: 17, "17", ">17","Компьютер")

 





Поделиться с друзьями:


Дата добавления: 2016-12-05; Мы поможем в написании ваших работ!; просмотров: 665 | Нарушение авторских прав


Поиск на сайте:

Лучшие изречения:

Велико ли, мало ли дело, его надо делать. © Неизвестно
==> читать все изречения...

818 - | 604 -


© 2015-2024 lektsii.org - Контакты - Последнее добавление

Ген: 0.01 с.